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Event Scheduler Pro Software
The Primex Event Scheduler Pro is a software program that create and manages the schedules for the XR Bell Scheduling system
and XR Programmable Timers.
Bell Scheduling: program multiple bell schedules. Simply create the schedule and the schedule can be either automatically
downloaded to the Transmitter from your computer or manually downloaded from your computer to the Transmitter.
Programmable Timers: schedule Programmable Timer countdown events, such as a count down between classes or a count down
for breaks and lunch periods. You will create a schedule of recurring countdown events. The timer begins counting down at each
event programmed into the schedule. When a countdown event is complete, the timer automatically displays the current time.
Multiple Schedule ID Applications: when using more than one Wireless Tone Generator to control events in different zones within
your facility, then a separate Wireless Tone Generator is needed for each zone. Each Wireless Tone Generator is set to a unique ID
switch setting that corresponds to its Schedule ID number in the Schedule ID Coordinator window in the Event Scheduler Pro
software.
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Install Event Scheduler Pro Software
Operating System Compatibility - Event Scheduler Pro
l

Windows 7, 8 and 10. Administrator rights are required for installation.

l

Not compatible with Apple operating systems.

How to install the Event Scheduler Pro software
Prior to installation, uninstall any previous version of the Primex Event Scheduling software.
Before beginning installation, it's recommended to close all other applications.
1. Verify operating system compatibility.
2. Insert the Primex Event Scheduler Pro CD into your computer CD-ROM drive.
3. Click on the Start button, scroll up and select Run. Type d:\setup, where ”d” is your CD-ROM drive letter. If “d” is not your CDROM drive letter, substitute the correct letter. Press Enter on your keyboard or click OK.

4. The Install Shield Wizard opens to guide you through the setup progress. Once the Install Shield Wizard is installed, it's ready
to install the Primex Event Scheduler Pro on your computer. Click Next.
5. The Read Me Information screen appears with operating system compatibility information. Review and click Next.
6. From the Customer Information screen, enter a User Name and Organization (optional), click Next.
7. The Setup asks you where to install the Scheduler files. Click Next to accept the default directory or click Change.
8. You will be given an opportunity to review the installation settings. Click Back to make any changes. Click Install to continue
installing the Scheduler. The Install Shield copies the Scheduler files to your computer.
9. When installation is completed, click Finish to exit Install Shield. On certain operating systems you may be asked to restart
Windows to complete the installation. If so, click Yes to reboot your computer.
The Primex Event Scheduler Pro is now installed on your computer.
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Configure and Maintain Schedules
From the Event Scheduler Pro software you can easily configure and maintain the schedules for your XR Bell Scheduling system
and XR Programmable Timers. Schedules are stored in the Transmitter’s memory and can be easily changed from the Event
Scheduler Pro software.
Once a schedule is created, it's required to be downloaded to the Transmitter. A schedule can be set to download the schedules
daily to the Transmitter or you can manually downloaded the schedules to the Transmitter from your computer.
The Event Scheduler Pro accommodates up to 25 different schedules. Each schedule can be customized to your needs. A
schedule can support up to 96 single events.

Single, repeating daily schedule: a single, repeating daily schedule sets the same schedule of events for all days of the week. Each
day, the same schedule will run on the selected days of the week. A single, repeating schedule may be programmed with up to 96
events.
Weekly, repeating schedule: a unique schedule of events for each day of the week. For this schedule, a single schedule is created
for each day of the week and each week the same weekly schedule will run. The schedules automatically run in sequence for seven
days; the sequence then repeats for each subsequent week. Up to seven unique schedules can be programmed, one for each day of
the week. To create a weekly, repeating schedule, the Daily Download Capability setting is required to be enabled for each schedule.
Date specific schedule: a schedule that only runs on a specific date. After the date specific schedule has ran, the program returns to
its previously programmed schedules. To create a date specific event, the schedule’s Daily Download Capability setting is required
to be enabled.
Multiple applications: if your facility uses multiple zones, each schedule can be configured as a single zone. To use multiple zones,
one Wireless Tone Generator is required for each zone. The Wireless Tone Generator switch ID is set to the schedule's Schedule ID.
XR Bell Scheduling event: an event is a scheduled time when a tone or a contact closure is sent by the Wireless Tone Generator to
the PA and/or bell system. A schedule supports up to 96 single events.
XR Programmable event: an event is a scheduled time a timer will count down in minutes and seconds from 1 minutes to 99 minutes
59 seconds and when the timer stops the count down event. A timer's schedule is required to be set to Scheduler ID 24 and the
event type ON indefinitely tells the timer when to start the count down event and the OFF indefinitely event tells the timer when to
stop the count down event.
Daily download capability: you can set your schedules to be automatically downloaded daily to the Transmitter. To use the daily
download capability, it's required to maintain a direct connection between the computer that has the schedules and the Transmitter
and the Event Scheduler Pro software is required to be open on the computer at all times. If the computer is required to be shut
down at night, set the automatic download time to occur just after the last scheduled event, but before the computer is to be
turned off.
Schedule ID Coordinator XR Bell Scheduling: the schedule's Schedule ID Coordinator setting corresponds to the switch ID on the
Wireless Tone Generator. For example, if a schedule is programmed to Schedule ID Coordinator 01, this schedule is downloaded to
the Wireless Tone Generator that has its switch ID set to 01. When a schedule is downloaded to a Transmitter, the Transmitter
downloads the schedule to the corresponding Wireless Tone Generator.
Schedule ID Coordinator XR Programmable Timers: the schedule's Schedule ID Coordinator settings is required to be set to 24 to
schedule a timer event. An ON indefinitely event is tells the timer when to start the count down and the OFF indefinitely event tells
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the timer when to end the count down. Once the timer receives the ON indefinitely event, it searches for the next OFF indefinitely
event. Upon finding both the ON and OFF indefinitely events, the timer calculates the time between the two events and counts
down the difference between these two events.

Topics in this section include:

Open Event Scheduler Pro Software
1. Open the Primex Event Scheduler Pro by double-clicking on the program icon located on your computer’s desktop or from
the Program file menu.

2. The first time you open the software, you are required to enter the default password and set a new password.
Default password: 9bhfd28zp

NOTE
Password is case sensitive. If you forget your password, you will need to uninstall and reinstall the program to regain
access.

3. Click OK.
The main schedule window appears; displaying a sample schedule. You can modify sample schedule or create a new schedule.
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Create a Schedule ID
The Primex Event Scheduler Pro accommodates up to 25 different Schedule ID assignments. Each Schedule ID can be customized
to your needs. If your facility uses multiple zones, each ID can be configured as a single zone. To use multiple zones, one Wireless
Tone Generator is required for each zone.

How to create a Schedule ID
1. From the top menu, click File > New.
2. A box may appear asking “Save Changes”, click “Yes” to save or “No” to not save changes as a file on your computer.
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3. From the Current File not downloaded to Transmitter Create new file? window, click Yes.
4. From the Schedule ID Coordinator field, select the Schedule ID number to create by clicking on the on the number from the
dialog box.
The schedule ID has been created. You can now create the schedule's events.

Create Programmable Timer Schedule
The Programmable Countdown Timer allows the user to count down in minutes and seconds any predetermined time from 1
minute to 99 minutes 59 seconds. The Programmable Countdown Timer functions in much the same way as a standard digital
clock.
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How to create a Programmable Timer Schedule
1. In the software, set the Schedule ID Coordinator setting to 24.
2. Double-clock on an event ID and create an ON indefinitely event to tell the timer when to start timing. An example of this is
shown in the figure below. Note the Schedule ID 24 being used in the upper left hand corner.

3. Next, an OFF indefinitely event must be scheduled to tell the timer when to turn off.

4. After you have created all the events, the schedule program must be downloaded to the Transmitter. To learn more, view
"Download Schedule to Transmitter" on page 15.
Once the timer receives the schedule from the Transmitter and it receives the ON indefinitely event, it will search for the next OFF
indefinitely event. Upon finding both the ON and OFF indefinitely events, the timer will calculate the time between these events
and count down this time difference on the display. As the timer counts down, the colons will flash, letting the user know that it
is in countdown mode, not normal time mode. Once the timer reaches 0, it goes back to the normal time display.
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NOTE
A countdown cannot be scheduled to either end on or cross over 12:00 AM (midnight). It can, however, begin on 12:00
AM. For example, 11:55 PM to 12:05 AM or 11:00 PM to 12:00 AM will not work, but 12:00 AM to 12:10 AM will.

Enter a Single, Repeating Daily Schedule with Manual Schedule Download
To do this, be sure the “Yes” box under “Enable Daily Download Capability?” is not checked. A single schedule may be
programmed with up to 96 events, and this schedule will repeat on all days during the week that were selected in the software
column under “events”. Each week, the same schedule will run on the selected days of the week.

Event Scheduler Pro software can be used to program the daily function of one or more Wireless Tone Generators. The Schedule
ID in the software corresponds to the Switch ID’s on the Wireless Tone Generator. Specifically, if a schedule is programmed on
Schedule ID ‘01’, this schedule is selected on the tone generator by setting the Switch ID on the tone generator to ‘01’.
The first Schedule ID used in software, should be set at ID ‘01’ in the “Schedule ID Coordinator” window. This is because if no
schedule is set on ID ’00’ switching the Wireless Tone Generator to ID ‘00’ can be used to turn off the tones/bells. Alternate
schedules may be programmed under Schedule ID ‘02’, ‘03’, etc. and selected manually using the ID switches on the Wireless
Tone Generator.

Specify the Time that Schedules are Downloaded to Transmitter
Unlike the manual downloading procedure, “Entering a Single, Repeating Daily Schedule with Manual Schedule Download”, with
Weekly or Date specific schedules there are periodic automatic daily downloads that occur at user specified times. This is done
under “”View”, “Options”, Transmitter Download Time setting.

File downloads are performed automatically according to the download time specified. This time is tied to the computer's time.
To allow schedules to be automatically downloaded to the Transmitter:
l

l
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A permanent serial connection is required to be established between the computer the schedules are saved to and the
Transmitter.
Event Scheduler Pro software is required to be open on the computer connected to the Transmitter at all times. If the computer
is shut down at night, set the automatic download time to occur just after the last scheduled event, but before the time the
computer is to be turned off.
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Options - Transmitter Download Time

Enter Entire Week Schedule
Select the “Yes” box under “Enable Daily Download Capability?” to allow multiple schedules to be automatically sequenced
during a week. Up to seven unique schedules may be programmed, one for each day of the week. These will automatically run in
sequence for seven days; the sequence repeats for subsequent weeks.

In the “Default Daily Downloaded Schedules” box, highlight the day of the week that you want to schedule by clicking on the day
in the dialog box. A message may pop up stating “Proceeding without saving will nullify any changes made to the current days
file. Continue?” Click yes to continue. A “Weekly Viewing/Editing Options” box appears with three choices:
l

The first choice allows you to preview the schedule file that is currently loaded, without the capability or risk of making
changes.
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l

l

The second choice will create a new, blank schedule to edit, which will need to be saved to a file when editing is complete.
The third choice opens an existing file with a previously entered schedule for the day of the week selected. After editing, the
file will need to be resaved.

With the second or third choice above, use the same steps as described under “Entering a Single, Repeating Daily Tone Schedule”
to enter the events you want to schedule, for the day of the week selected. After each day that you schedule or edit, always save
your schedule by clicking “File” then “Save As”, naming the file as desired. For example Monday's schedule might be named
“Monday”. Repeat this process for each day of the week that you want to schedule.

NOTE
If a file is not saved for specific day of the week, there will be no bells/tones on that day. Be sure to save schedules under
each day of the week.

Enter a Date Specific Event Schedule
Select the “Yes” box under “Enable Daily Download Capability?” This will enable you to use the “Special Date Scheduling
Calendar” to assign a unique schedule to run on a specific date in the future.
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Click on the date on the calendar that you want to program as a “special event schedule”. A “Calendar Viewing/Editing Options”
box appears with three choices:
l

l

l

The first choice allows you to preview the schedule file that is currently loaded, without the capability or risk of making
changes.
The second choice will create a new, blank schedule to edit, which will need to be saved to a file associated with the selected
date after editing.
The third choice opens an existing file with a previously entered schedule for the date selected on the calendar. After editing,
the file will need to be resaved.

With the second or third choice above, use the same steps as described under “Entering a Single, Repeating Daily Tone Schedule”
to enter the events you want to schedule, for the calendar date selected. Remember to save your file before taking any other
actions.
After a date specific schedule has run, the program will then return to its previously programmed weekly schedule.
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Download Schedule to Transmitter
If a schedule does not have the Daily Download Capability? setting enabled, each time a new schedule is created or an existing
schedule is edited, the updated schedule is required to be downloaded to the Transmitter.

Requirements
l

l

Supplied RS232 (DB9F/DB9M) serial connector cable
If your computer does not have a serial port, a USB to serial adapter with a FTDI chip set is required. Other adapters may not
function properly. For further assistance, contact Primex Technical Support at 1-262-729-4860.

How to manually download a schedule to a Transmitter
1. Bring your computer to the location of the Transmitter.

NOTE
Alternatively, if you need to bring the Transmitter to the location of your computer, unplug the GPS unit or repeater from
the back of the Transmitter, unplug the power cord from the Transmitter, remove the antenna from the Transmitter and
carry the Transmitter and power cord to the computer which has the Primex Event Scheduler Pro software installed on it.

2. Connect your computer to the Transmitter using the supplied RS232 (DB9F/DB9M) connector cable. Attach the male end to
the computer connection port on the back of the Transmitter and attach the female end to the serial port on the computer.
The cable is a straight serial configuration; a prolific cable cannot be used.

NOTE
If your computer does not have a serial port, a USB to serial adapter with a FTDI chip set is required. Other adapters may
not function properly. For more information or recommendations, please contact Primex Technical Support.

NOTE
If the serial cable does not reach between the Transmitter and your computer, an alternative method is the use of two
Primex Data Transceivers. A Wireless Data Transceiver creates a wireless link between a computer and Transmitter.
Connect one transceiver is to the Transmitter and connect the other transceiver to your computer to download the
schedule.

3. Prior to downloading the schedule, it's recommended to set your computer's port to Com1. From the Primex Event Scheduler
Pro software, select View > Options and select Serial Port COM1, click OK.
4. From the top menu, select Transmitter > Download to. If you have not already saved this schedule, a box appears asking if
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you want to the Save Changes, click on Yes to save.
5. A box will appear asking if you want to overwrite data in the Transmitter, click OK to overwrite.
The Transmitter Status box appears and a blue bar displays the progress of the data transfer. When the data transfer is complete,
the word "Saving" changes to "Save Complete!", and the blue bar is full. The typical transfer time duration can be up to 30
seconds.

NOTE
If there is a problem with the data transfer, a Transmitter Download Error box will appear. Click OK and verify that the
cable is firmly connected. Then retry the data transfer. Also, check that the correct communication port is selected and
the correct download cable is used. If there are still problems, contact Primex Technical Support.

6. Once the data transfer is complete, remove the connector cable from the Transmitter and the computer.

Open a Saved Schedule
From the top menu, select File > Open. Select the file to open, either double-click on the schedule name or select the Open
button.
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Save a Schedule to as a New Schedule
To create a new schedule from an existing file, you can use of the File Save As function. The Save As function is a standard
function that is commonly available in software programs.

How to save a schedule as a new schedule
1. Open the schedule file.
2. From the top menu, select File > Save As.
3. Enter the name of the file.
4. Select a directory to save the new file.
5. To save the new file, click Save.

Delete Events
You can delete a single event or all events as defined below.

How to delete a single event
1. Open the Schedule ID, double click on the Schedule ID From the top menu, select File > Edit > Schedule ID, Info. the Schedule
ID information box is displayed.
2. Double click on the event to delete.
3. Delete the text in the Name field.
4. Change the event type to none.
5. To exit the event, click on the X in the upper right hand corner of the Event Information box to.
The single event is deleted.

How to delete all events
1. Open the Schedule ID, double click on the Schedule ID.
2. From the top menu, select File > Edit > Schedule ID, Info. The Schedule ID information box is displayed.
3. Click Delete All Events.
4. A box pops up asking Delete All Events for ID?” click Yes; or click No to cancel the deletion.
5. To exit, click on the X in the upper right hand corner of the Schedule ID Information box.
All events are deleted for the selected Schedule ID.
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Copy and Paste Schedule IDs and Events
This can also be done by using the right mouse button.

How to copy Event information from one Schedule ID to another
1. Click on the Schedule ID containing the information you wish to copy.
2. Select Edit.
3. From the drop-down menu, select the Schedule ID.
4. Select Copy.
5. Click on the Schedule ID to you wish to copy the information to.
6. Select Edit.
7. From the drop-down menu, select Schedule ID > Paste.
8. A window appears asking if you wish to overwrite the data in ID # __(the Schedule ID you are copying to. Verify the Schedule
ID is correct and click Yes to paste the information into the selected schedule ; or No to cancel.

How to copy information from one Event to another
1. Click on the Event containing the information to copy.
2. Select Edit.
3. From the drop down menu, select Event.
4. Select Copy.
5. Click on the Event to which you wish to copy the information to.
6. Select Edit.
7. From the drop-down menu, select Event >Paste.
8. A box appears asking if you wish to overwrite the data in ID # __ Event # __ (event you are copying to). Verify the Schedule ID
and Event is correct. Click Yes to paste the information, No to cancel.
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Configure Settings
You can set general settings for Event Scheduler Pro software. The general settings include the time schedules are download to
the Transmitter, location of file backups, time format schedules are displayed in, and the software login password.

Topics in this section include:

Set the Daily Download Time Schedule
When a schedule's Daily Download Capability setting is enabled, the schedule is automatically downloaded each day to the
Transmitter at the time specified in the Transmitter Download Time setting. The time is determined by the user's computer time.

Requirements
To allow schedules to be automatically downloaded to the Transmitter:
l

l

A permanent serial connection is required to be established between the computer the schedules are saved to and the
Transmitter.
Event Scheduler Pro software is required to be open on the computer connected to the Transmitter at all times. If the computer
is shut down at night, set the automatic download time to occur just after the last scheduled event, but before the time the
computer is to be turned off.

How to view or set the Transmitter Download Time setting
1. From the top menu, select View > Options.
2. From the Transmitter Download Time section, set the hour, minute, and meridian settings.
3. To save, click OK.
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Set File Backups
You can set the Event Scheduler Pro software to backup your schedule files, including selecting the file location of the backup
files. When backups are enabled, the software automatically creates a backup of the file when you open the file itself. When
creating a new file, a backup is not created until the file is saved and reopened.

NOTE
A backup file cannot be opened directly from the backup file location. To open a backup file, copy the backup file and
paste it into your normal Primex Event Scheduler Pro directory, then proceed to open it.

How to enable backups and set a backup file location
1. From the top menu, select View >Options. The Options box is displayed. The backup settings are located in the Backup
section.
2. From Create backups of open files, select the checkbox to enable backups.
3. From the Backup Folder, select Browse and select a location the backups are to be saved to. It's recommended to save the
backups to a location other than your local computer.
4. To save, click OK.

Set the Event Scheduler Pro Schedules to Display in 12 or 24-hour Format
You can set a schedule to be displayed in either a 12 or 24-hour time format.
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How to set to 12 or 24-hour time format
1. From the top menu, select View > Options. The Options box is displayed. The time format is listed in General section.
2. From the Time Format drop-down menu, select a time format.
3. To save, click OK.
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Change Event Scheduler Pro Password
You can change the login password of the Event Scheduler Pro software installed on your computer.

How to change the password
1. From the top menu, select Account > New Password. The Create Password box appears.
2. Enter the new password.
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Support
To obtain additional technical documentation for Primex products, visit the Support area on our website at www.primexinc.com
You may require Technical Support when you have questions about product features, system configuration, or troubleshooting.
Support services are delivered in accordance with your organization's support agreement, end user licenses agreements, and
warranties, either with a Primex Certified Sales and Service Partner or directly with Primex.

Support through Primex Certified Sales and Service Partners
Ensuring our customers experience excellent service is of utmost importance to Primex. Our network of Certified Sales and
Service Partners offer technical support services for Primex products.
If you have purchased Primex products or have a service agreement with a Primex Partner, they are your primary contact for all
Technical Support inquires.

When contacting Primex Technical Support
Make sure you have satisfied the system requirements listed in your product documentation. Also, you should be at the
computer or device on which the problem occurred, in case it's necessary to replicate the problem.
When you contact Primex Technical Support, please have the following information available:
l

Customer ID/Account Name

l

Problem description/error messages

l

Device hardware information

l

Troubleshooting performed before contacting Primex

Primex Technical Support
Hours: 8:00 a.m. to 5:00 p.m CST | Monday through Friday
Phone: 1-262-729-4860
Email: techservices@primexinc.comtechservices@primexinc.com | Web: www.primexinc.com/support
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