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SNS CONFIGURATION TOOL ADVANCED USE (CLASSIC SERIES CLOCKS ONLY)

Commonly, a network is assigned to a clock during device preconfiguration and any subsequent network changes are then managed
from your OneVue account.

From the SNS Configuration software, you can manually configure the network settings of a Classic Series Clock/Timer. You can also
perform network related troubleshooting procedures and install EAP-TLS certificates.

Minimum System Requirements

The following table details the minimum system requirements for the Primex SNS Clock Configuration Tool software.

System Requirement Minimum

Operating System Windows 7 32 and 64 bit, Windows 8.1 64 bit

Supporting Software Microsoft .NET Framework version 2.0 or later

Disk Space Required 10 MB

Computer RJ-45 jack/Ethernet

Network Cable 1 Cat 5 wired straight through with RJ- 45 connectors

Minimum Screen Resolution 1024 x 768
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Instal l the SNS Conf iguration Tool Software

Uninstall any previous versions before beginning this procedure. .

How to install the Primex SNS Configuration Tool software

1. Download the software from the online help.

2. Double-click the PW Config Tool Setup.zip file and Unzip the file.

3. Double-click the PW Config Tool Setup.msi file to install the software. The Setup Wizard will guide you through the installation
process.

4. Click Next. The Select Installation Folder dialog box opens with the default installation path already entered in the Folder field.

5. (Optional) To install the configuration tool in a location other than the default location, click Browse. The Browse for Folder
dialog box opens. Using the drop-down list box, select the desired location for the installation, and then click OK to accept the
new location and return to the Select Installation Folder dialog box.

6. (Optional) To view the impact of installing the software on your computer, click the Disk Cost button. The Disk Cost button
displays all available drives on your computer with their disk size, free space available, the amount of space required to install the
configuration tool, and amount of space remaining after installation of the configuration tool.

7. Click OK.  The Select Installation Folder dialog box reappears.

8. Select the level of access.

Just Me: you are the only one to have access to the configuration tool. This is the recommended choice.

Everyone: anyone signed into your computer has access.

9. Click Next. The Confirm Installation page appears.

10. To begin the installation, click Next. Or, click the Back button to return to the Select Installation Folder dialog box, or click the
Cancel button to exit the installation process without making any changes to your computer.

When the installation begins, a progress meter shows the installation progress.

11. When installation is complete and the Installation Complete page appears, click Close.

12. To close the wizard, click Close.
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User Interface

The user interface consists of the Menu bar, Title bar, Tool bar, Tabs, and Status bar indicator.

Menu bar

The menu bar is a strip along the upper portion of the window that has several words on it. Each word represents a group of related
commands that you can perform by selecting the desired command from a list. When you click a word on the menu bar, the menu
drops down to allow you to make your selection.

Title bar - icons and commands specifications

Name Description

System Menu

Click the system menu icon at the left edge of the title bar (or use the keyboard shortcut {Alt} + {Spacebar}) to display a menu with
some or all of the following commands

Restore After maximizing or minimizing a window, choose the Restore command to restore the window to
its previous size.

Move Choose the Move command to move the Configuration Tool window using the keyboard arrow
keys. When you have finished moving the window, press the Enter key to stop moving the window
and return to normal mode.

Size Choose the Size command to adjust the size of the Configuration Tool window using the keyboard
arrow keys. When you have finished resizing the window, press the Enter key to stop resizing the
window and return to normal mode.

Minimize Choose the Minimize command to minimize the Configuration Tool window to a taskbar button.
To restore the minimized window to its previous size, click its taskbar button.

Maximize Choose the Maximize command to maximize the Configuration Tool window to cover the full
screen. You can also double-click the title bar to maximize it, or restore it to its previous size.

Note: The ability to resize/maximize is disabled by default but can be changed with the Window
resizable setting on the Set preferences dialog box.

Close Click the Close command to shut down the Configuration Tool program. This is the same as
choosing the File > Exit command or the System > Quit command.

Title bar text

This area displays the name of the software, for example, Configuration Tool

Minimize button Click the Minimize button to keep the program running but move it to the taskbar. This allows you
to access other programs without exiting the current program. Clicking the Minimize button is the
same as choosing the Minimize command on the System menu.

Restore/Maximize buttons

Restore Click the Restore button to reduce the program window to its last non-maximized size, and
convert the Restore button to a Maximize button. This is the same as choosing the Restore
command on the System menu.
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Name Description

Maximize Click the Maximize button to enlarge the program window to fill the entire screen, and convert the
Maximize button to a Restore button. This is the same as choosing the Maximize command on the
System menu.

Note: The ability to resize/maximize is disabled by default but can be changed with the Window
resizable setting on the Set preferences dialog box.

Close button When you click the Close button, the program is shut down. This is the same as choosing the Quit
command on the System menu.

Tool bar

The tool bar has 22 buttons, most of which correspond to menu commands. The tool bar and its commands are specified below.

Button Menu Equivalent Button Menu Equivalent

File>New>Analog Clock Configuration Actions>Search Mode

File>New>Digital Clock Configuration Actions>LED Test Mode

File>Open… Actions>Perform Site Survey

File>Save… Actions>Upgrade Radio Firmware

File>Save As… Actions>Upgrade Clock Firmware

File>Print… Show Network Information

Actions>Connect Ping Device

Actions>Disconnect Copy Communication Log

Actions>Read Configuration Save Communication Log

Actions>Write Configuration Print Log

Actions>Set Password Edit>Preferences

Actions>Set Hands to 12:00
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Tabs

The tab bar allows you to access additional features.

Tab Definition

Clock
Configuration

The Clock Configuration tab is used to configure analog clocks or digital clocks/timers.

Communication
Log

While active, the Configuration Tool keeps a log of all the communication sent and received between it and the
devices it establishes a connection with. The log is cleared each time you exit the application and a fresh log is
started each time the application is started. You can view the current log at any time by clicking the
Communication Log tab.

Time Zones The Time Zone tab can be used view what time zones are available and what DST transition dates are stored for
each time zone, if any.

Site Survey The Site Survey allows you to use the wireless radio in the connected clock to scan for available Wireless Access
Points in the current location and view the quality of signal received from each access point discovered.

Status bar indicator

The status bar, located in the lower left of the window, displays the current connection status between the software and a clock.
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Setting Speci f ications

When connecting to a clock and selecting Read Configuration, the settings of the clock are displayed.

Note:
Settings marked with an asterisk * are only managed from your OneVue account and are for information purposes only.
Therefore, changing a setting will not be applied to the clock.

Only the network settings entered into the software are configured into a clock when Write Configuration is selected.

Setting Specification

*Clock Name Name of clock.

*Time Zone Clock time zone.

*GMT Offset -14:00 to +14:00, the offset from Greenwich Mean Time (GMT) that the clock
should display. The format is hh:mm. The field text will turn red if it contains
an invalid value.

*Use Daylight Saving Time Indicate whether the clock adjusts its time for Daylight Saving Time.

MAC Address The read-only MAC Address field is populated with the MAC address of the
clock currently connected to the configuration tool.

Hardware The read-only Hardware field is populated with the hardware version of the
clock currently connected to the configuration tool.

Clock The read-only Clock field is populated with the clock firmware version of the
clock currently connected to the configuration tool.

Radio The read-only Radio field is populated with the radio firmware version of
the clock currently connected to the configuration tool.

Display Settings (SNS digital clock/timers only)

Use the Display Settings to control how the clock display appears in normal operation.

*LED Level The brightness of the LED display.

*Display Mode Display Mode of how time is displayed on the clock.

*Show PM Indication Show PM Indication to instruct the clock to display the PM indicator.

*Display Time & Date (alternately) Clock alternates display between time and date.

*Time Display Period (seconds) Clock alternates displaying the time and date and amount of time of the
alternating cycle.

*Date Format The format of the date display.

*Enable Buzzer Enable or disable the buzzer for elapsed time models only.

NTP Servers
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Setting Specification

*IP address (1-3) NTP Servers used by the clock to synchronize its time.

The IP Address field must be a valid IPv4 address or DNS name for an NTP
Server. Some examples are:

time.microsoft.com

time.nist.gov

0.us.pool.ntp.org

Synchronization Settings (OneVue gateway Check-In Interval)

*Daily The clock check-in schedule is set once daily at a random time.

*Every 3rd day The clock check-in schedule is set to synchronize once every third day at a
random time.

*Scheduled The clock check-in schedule is set to synchronize once daily at a schedule
time(s).

Wired Network Settings

Use DHCP Yes/No checkbox set to indicate whether the clock should request a
dynamically assigned IP address each time it connects to the wired network.

IP Address The static IP address for the clock to use when connecting to the network.
The IP address must be a valid IPv4 address. The field text will turn red if it
contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Subnet Mask The subnet mask must be a valid IPv4 address mask. The field text will turn
red if it contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Gateway The network gateway IP address must be a valid IPv4 address. The field text
will turn red if it contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Wireless Network Settings

You have the option to enter information for up to three wireless network settings. The clock attempts to connect to the configured
wireless network settings in numeric order when synchronizing time and uses the first network setting to respond.

NOTE: If no network settings are entered, the clock will not be able to connect to the network to synchronize time or report its
condition.

SSID Service Set Identifier (SSID) 0 to 40 characters. The SSID for the wireless
network.

Use DHCP Yes/No checkbox set to indicate whether the clock should request a
dynamically assigned IP address network each time it connects to the
wireless network.
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Setting Specification

IP Address The static IP address for the clock to use when connecting to the network.
The IP address must be a valid IPv4 address. The field text will turn red if it
contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Subnet Mask The subnet mask must be a valid IPv4 address mask. The field text will turn
red if it contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Gateway The network gateway IP address must be a valid IPv4 address. The field text
will turn red if it contains an invalid value.

NOTE: Not required if Use DHCP is enabled.

Security Type Select from the available security types:

None | WEP | WPA | WPA2

Security Mode Not required if Security Type is set to None.

If Security Type is set to WEP, select: Shared or Open.

If Security Type is set to WPA or WPA2, select: AES or TKIP.

Security Key 8 to 63 alphanumeric or 64 hex

RADIUS Authentication type of the Radius Server.

Radius Username Username of the RADIUS server; 0 to 40 alphanumeric characters.

Radius Password Password of the RADIUS server;0 to 40 alphanumeric characters.

EAP-TLS Certificate

Certificate File Upload .PEM certificate file.
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Display Network Information

You can display the network settings in use by your laptop or PC while connected to the clock by selecting the Show Network
Information toolbar button or choosing the Show Network Infomenu item on the context menu shown when you right-click on the
Communications Log tab. This can be helpful in making sure the clock is allocating your machine a valid IP Address when it is
connected directly to the device.

Ping a Clock

The Primex Configuration Tool provides the ability to ping a clock it's connected to.

How to ping a clock

1. Click the Ping Device toolbar button or choose the Ping Devicemenu item on the context menu shown when you right-click on
the Communications Log tab.
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Conf iguration Templates

A configuration template can be used when a significant portion of the configuration settings are the same for all or a significant
number of clocks.

To facilitate this, once you have configured a clock, save the configuration settings as a template file for reuse at a later time. All the
information entered is stored in the file with the exception of the Clock Name, which you typically want to be unique for each clock.

To save the clock information in a template file, all the information fields must contain valid values.

How to save a configuration template file

1. From the top menu, click File > Save… or File > Save File As...

Note:
You will not be able to save the configuration settings to a template file if any of the fields contain invalid values (indicated with
red text). Attempting to do so will generate the following error dialog: Correct the invalid value and try again.

2. If you chose the Save Filemenu item on a set of configuration settings you previously read from a file, the data will be saved
back to that file. If you chose the File > New menu item to create the configuration settings or if you chose the Save File As…
menu item, the Configuration Tool software displays a Save As dialog box to allow you to select where the file should be saved.
By default, Primex SNS Configuration files are saved with a .pwc file extension, but you can use whatever name and extension you
prefer. Enter a file name and choose a location where you’d like to store the template file then click the Save button.

How to open a configuration template file

1. From the top menu, click File > Open…. The Configuration Tool software displays an Open dialog box to specify the
configuration template file you want to open.

Note:
If you have changed any data in the current configuration setting values displayed on the configuration tab you will be asked if
you want to save those configuration values before opening configuration template file.

2. Use the Open dialog box to browse to the configuration template file, select it and click the Open button.
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Communication Log

While active, the Configuration Tool keeps a log of all the communication sent and received between it and the clock it establishes a
connection with. The log is cleared each time you exit the application and a fresh log is started each time the application is started.

You can view the current log at any time by clicking the Communication Log tab. If an error occurred, it is displayed in the
Communications Log.

How to clear the communication log

1. Choose the Clear Logmenu item on the context menu shown when you right-click on the Communications Log tab.

2. Select the Clear Logmenu item to be cleared.

3. When prompted, confirm that you want to clear all the data from the Communications Log. The log is then cleared of all data.

How to copy the communication log

1. Use Edit > Copy to copy all or portions of the Communication Log. 

2. To copy the entire contents of the Communication Log to the clipboard so it can be pasted into a document or email message,
click the Copy Communication Log toolbar button. Or choose the Copy Entire Logmenu item on the context menu shown
when you right-click on the Communications Log tab. The contents are copied as rich text, so when pasted into a Microsoft Word
document, the contents will retain any color coding.

How to save the communication log

1. To save the Communication Log as rich text to a file, click the Save Communication Log toolbar button or choose the Save
Logmenu item on the context menu shown when you right-click on the Communications Log tab. The Configuration Tool
software displays a Save As dialog box allowing you to specify where to save the file and the file name to use.

2. Accept the default file name and location, or change it as needed. By default, the file name PrimexWirelessConfigLog.rtf is
used, but you can change this.

How to print the communication log

1. Click the Print Log toolbar button or choosing the Print Logmenu item on the context menu shown when you right-click on the
Communications Log tab.

2. When the standard Print dialog window opens, select the printer and options to use.

3. If desired, use the File > Page Setup… and File > Print Preview… menu items while displaying the Communication Log tab to
configure and preview what the printout will look like before sending it to the printer.
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Set Clock Password

A clock has a password which is required read the settings configured into the clock. The password used by the Primex SNS
Configuration Tool and is stored in the Preferences settings.

How to set the clock password

1. Verify a connection is established between the clock and software.

2. Click the Set Device Password toolbar button or choose the Actions > Set Device Password menu command. Both should be
enabled once a connection to the clock has been established.

3. Check for the message on the status bar at the bottom of the window. It will display “Device Password Set!”

Time Zone Information

Time Zone options and the Daylight Saving Time (DST) transition dates for each time zone are kept in a data file which is part of the
installation of the Primex SNS Configuration Tool software.

Time zone tab

The Time Zone tab can be used to view what time zones are available and what DST transition dates stored for each time zone, if any.

Each Time Zone entry in the display can be expanded or collapsed by clicking on the plus (+) or minus (-) character displayed before the
entry.
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Set Software Preferences

You can adjust several settings which affect how the software behaves for your installation only.

How to view or edit the software preference settings

1. Click the Edit Preferences toolbar button or choose the Edit > Preferences… menu item. The Configuration Tool displays a
Preference Settings dialog box.

2. Clicking on a color setting will display a drop-down which allows you to select a color value.

3. Clicking on a True/False setting will display a drop-down allowing you to pick either a True or False value.

Field Description

Device address By default, clocks in configuration mode act as DHCP servers to allocate IP Addresses to devices connected to
them and the devices use an IP Address of 192.168.1.1. The Primex Configuration Tool is configured to attempt to
connect to IP address 192.168.1.1 on port 1600 when attempting to connect to a clock.

Device
password

The device password is used by the Primex Configuration Tool to log in to clocks in order to read their current
settings. You can change this password from the default and set it in all of your devices using the Set Device
Password command if you wish to use a custom password in all of your clocks.

Device port Note: Do not change this unless instructed to do so by your IT security staff and/or Primex technical support.

Communication
log settings

The Primex Configuration Tool uses color coding when displaying messages in the Communication Log. These
settings allow you to adjust those color settings to your own personal tastes.

Only Decimal IP
Addresses

Set the Only Decimal IP Addresses drop-down list box to true to specify that IP Address fields should only accept
decimal values. Set the Only Decimal IP Addresses drop-down list box to false to specify that IP Address fields
may accept either decimal or octal values.

Read Battery
Voltage

Set the Read Battery Voltage drop-down list box to true to instruct the Configuration Tool software to read the
current voltage of the clock it’s connected to

Response
timeout mSec

Set the Response Timeout mSec value to the amount of time you want the Configuration Tool software to wait
before reporting a failure to communicate with the clock it’s connected to.

16 SNS Configuration Tool Software User Guide



Field Description

Upgrade port When performing a firmware update on a clock, the device pulls the information from the Configuration Tool.
This setting specifies what port the device should attempt to connect to the Configuration Tool software on in
order to pull the firmware upgrade file down. The default value of 5050 for this port should work fine in most
cases, but can be changed to another port if your laptop or PC already has an application using port 5050.

Window re-
sizable

By default, the Configuration Tool runs in a fixed size window. You can change this setting to allow the window to
be resizable. This can be advantageous when viewing the Communication Log tab, but the forms displayed by the
Configuration Tool will not resize and will simply be displayed in the upper left of the tab. Note that there is a
fixed minimum size set to make sure the entire form remains visible when being displayed.
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Instal l EAP-TLS Certi f icate

Complete the steps below to install an EAP-TLS Certificate to a clock. This procedure is commonly performed to replace an expired
certificate.

How to install a EAP-TLS Certificate

1. If the clock is mounted, dismount the clock to allow access to the back of the clock.

2. If the clock is powered, remove power from the clock. The way you do this depends on the clock’s power source.

Battery powered clocks: remove the batteries.

AC-powered clocks: be sure the clock is not plugged in to AC-power.

3. Connect an Ethernet cable between the clock’s Ethernet port and your computer’s Ethernet port. For PoE models, use of a PoE
Injector or batteries is required during configuration.

4. You will now set the clock into configuration mode, which is dependent upon the clock model.

For a... Then...

Battery-powered Analog Clock

Personal Series LCD Clock

For the Personal Series LCD PoE model,
use of batteries or a PoE Injector is
required

Battery powered clock:

Hold down the button on the back of the clock while inserting the batteries.

The clock will be ready for configuration in approximately 15-20 seconds.

Analog PoE clock with use of a PoE Injector:

Hold down the button on the back of the clock while inserting the Ethernet cable into
the RJ45 jack located on the side of the clock.

Release the button after the clock emits one beep, indicating that it's in configuration
mode.

The clock is ready for configuration after approximately 15-20 seconds.

AC-powered Analog Clock

AC-powered Personal Series LCD Clock

If power is applied to clock, disconnect power.

Hold down the button on the back of the clock and apply power to the clock.

Release the button after the clock emits one beep, indicating that it's in configuration
mode.

The clock is ready for configuration after approximately 15-20 seconds.

Classic Digital LED Clock/Timer Apply power to the clock/timer.

Remove the panel located on the top of the face plate by inserting a flat blade screw
driver in the small gap in the seam.

Press and release the Config Mode button. The clock displays Con, indicating it's
entering configuration mode.

Wait for the first two LED circle segments located the bottom of the display to
illuminate. Once illuminated, the clock is ready for configuration after approximately
40 seconds.

5. You are now ready to use the Primex SNS Configuration Tool to enter the clock settings. From your computer’s Start menu, click
Programs>Primex SNS >SNS Configuration Tool or double-click the SNS Configuration Tool icon
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on your computer’s desktop. The Primex SNS Configuration Tool is displayed. The status bar at the bottom of the
window displays “Not Connected”.

6. From the top menu, select Actions > Connect to establish a connection to the clock.

The status bar at the bottom of the window displays either a “Connected!” or “Connection Failed!” message depending on whether
the connection to the clock succeeded or failed.

The clock model image, its Media Access Control (MAC) Address and hardware/clock/radio version numbers are displayed in the
upper left corner of the Clock Configuration tab.

After the connection has been established, the other Action menu commands and toolbar buttons are enabled and no longer
grayed out.

7. From the top menu, select Actions>Read Configuration. The status bar at the bottom of the window displays a “Configuration
read from device!” message and the fields on the Configuration tab are updated with the configuration values read from the
clock.

8. Select the EAP-TLS Configuration tab.

9. From the Certificate File, select Open and select the certificate file (.pem file required).

10. From the top menu, select Actions > Write EAP-TLS Certificate.

11. From the Completed - EAP-TLS Certificate Loaded! notification window, select OK.
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12. From the top menu, select Actions > Disconnect.

13. Remove the Ethernet cable from the clock and computer. For PoE models, do not remove Ethernet cable from clock and connect
the other end of the Ethernet cable to a PoE enabled LAN port.

14. You will now initiate the clock’s connection and check-in to your OneVue account to validate the network connection.

For a... Then..

Analog Clock or
Personal Series LCD
Clock

Quickly press and release the button on the back of the clock to initiate a check-in.

The clock emits a double-beep when the check-in sequence has started.

The clock emits another series of beeps indicating the clock is connecting to your facility’s network to
check-in to your OneVue account and synchronize its time with an NTP Server.

l One beep - initialized its radio

l Two beeps - connected to network

l Three beeps - received NTP time

l Four beeps - connected to OneVue

After approximately 20 to 30 seconds, the clock automatically set its time.

It's recommended to validate the clock can successfully check-in at its permanent installation location.

Digital LED
Clock/Timer

Press and release the Reset button located in the top panel. The four LED circle segments illuminate in
sequence, indicating the following check-in connection sequence:

1 LED circle - initialized its radio

2 LED circles - connected to network

3 LED circles - received NTP time

4 LED circles - connected to OneVue

. ‘- - - -‘ is shown on the LED display while the clock is waiting for the synchronized NTP time.

After approximately 20 to 30 seconds, the clock automatically set its time.

Replace the top panel insert.

It's recommended to validate the clock can successfully check-in at its permanent installation location.
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Manual ly Conf igure the Network of a Device Gateway

Commonly a network is assigned to a clock during device preconfiguration and any subsequent network changes are then managed
from your OneVue account.

The network settings can also be manually configured locally at the clock.

During manual configuration, you download an encrypted file (.pwg extension) from a gateway profile from your OneVue account.
The file includes your OneVue account ID and the network profile(s) assigned to the gateway profile.

Using the downloaded file, you download the settings to the clock. For a Classic Series Clock you use of the Primex SNS Configuration
Tool software. For a Levo Series Digital Clock/Timer you use the Primex Device Configuration software.

Learn about when manual configuration is commonly performed

l During device preconfiguration, a network profile was not assigned to the clock.

l During device preconfiguration, the settings of the assigned network profile were not correct and the clock cannot establish a
connection to the network.

l When troubleshooting network connection issues. You may need to manually configure the network settings locally at the clock,
which will allow the clock to connect to your OneVue account and migrate to a new network profile.

l When your information security policies restrict storing network setting data in third-party applications. Manual configuration
allows the network settings to be configured locally at the clock. When configured locally, the network settings are not
transmitted or stored in your OneVue account. Once configured any subsequent networks changes are required to be manually
configured for each clock if your organization's policy restricts network setting to be stored in your OneVue account.

l When a clock gateway uses EAP-TLS authentication. The certificate file (.der file type) is uploaded to the device during manual
configuration.

Step 1 - download manual configuration file

The first step of manually configuring the network settings of a clock gateway is to download a manual configuration file from a clock
gateway profile within your OneVue account. This file contains your OneVue account ID and the network profile(s) assigned to the
gateway.

Note:
If you are performing this procedure due to the settings of the network profile assigned during device preconfiguration were
not correct, first create a new network profile with the correct settings and then set the gateway migration network to the new
network profile before you begin this procedure.

1. Go to Devices > Gateways.

2. From the list, select the Gateway ID link of the gateway.

Note:
You can optionally select any gateway that has network profile(s) that are to be manually configured into the clock gateway.

3. Select Show Advanced Options.

4. Verify the assigned network and alternate network (if applicable) are correct. The network profiles are download to the gateway
and used by the gateway to check-in to your OneVue account.
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Note:
If your security policies restrict network settings to be stored in your OneVue account, in which your OneVue account does
not have network profiles, the network settings can be entered directly within the Primex Device Configuration software.
Downloading the manual configuration file is still required, due to it contains your OneVue account ID.

5. From the Manual Configuration File option, select Download.

6. If you have change the Primex SNS Configuration Tool software default password, enter the Configuration File Password. If you
have not changed the password on your local computer, leave as is.

7. If you require that a user performing the manual configuration cannot view the details of the network profile settings within the
software, select the Hide Configuration option. When Hide Configuration is selected, the software restricts a user to only write
the network settings to a clock.

8. Select OK.

9. From the system prompt, select Save. By default the file is saved to your computer's Downloads folder and is named
device.pwg. To copy the file to another location, select Open Folder and copy the file to the desired location.

You can now proceed the next step.

Classic Series Models > Step 2 - upload manual configuration file to clock

The second step of manually configuring the network settings of clock gateway is to upload the manual configuration file downloaded
from the gateway profile to the clock.

Requirements

l Classic Series Clocks/Timers only - install the SNS Configuration Tool software on the computer. The software can be download
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from the online help.

l Levo Series Clocks/Timers only - install the Primex Device Configuration software on the computer. The software can be
download from the online help.

l Computer with Ethernet port.

l Ethernet cable.

l For PoE models, use of a PoE Injector or batteries is required.

l Manual configuration file (.pwg extension) - downloaded from the gateway profile. If the gateway profile did not have an
assigned network, you will be required to enter the network settings during this procedure.

l For EAP-TLS authentication, the certificate .der file is required. This file is uploaded to the clock during configuration.

To uploadmanual configuration file to clock

1. If the clock is mounted, dismount the clock to allow access to the back of the clock.

2. If the clock is powered, remove power from the clock. Battery powered clocks - remove the batteries. AC-powered clocks - be
sure the clock is not plugged in to AC-power.

3. Connect an Ethernet cable between the clock's Ethernet port and your computer's Ethernet port. It's recommended to
temporarily turn off your computer's wireless radio.

4. You will now set the clock into configuration mode, which is dependent upon the clock model.

For a... Then...

Battery-powered Analog Clock

Personal Series LCD Clock

For the Personal Series LCD PoE model,
use of batteries or a PoE Injector is
required

Battery powered clock:

Hold down the button on the back of the clock while inserting the batteries.

The clock will be ready for configuration in approximately 15-20 seconds.

Analog PoE clock with use of a PoE Injector:

Hold down the button on the back of the clock while inserting the Ethernet cable into
the RJ45 jack located on the side of the clock.

Release the button after the clock emits one beep, indicating that it's in configuration
mode.

The clock is ready for configuration after approximately 15-20 seconds.

AC-powered Analog Clock

AC-powered Personal Series LCD Clock

If power is applied to clock, disconnect power.

Hold down the button on the back of the clock and apply power to the clock.

Release the button after the clock emits one beep, indicating that it's in configuration
mode.

The clock is ready for configuration after approximately 15-20 seconds.
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For a... Then...

Classic Digital LED Clock/Timer Apply power to the clock/timer.

Remove the panel located on the top of the face plate by inserting a flat blade screw
driver in the small gap in the seam.

Press and release the Config Mode button. The clock displays Con, indicating it's
entering configuration mode.

Wait for the first two LED circle segments located the bottom of the display to
illuminate. Once illuminated, the clock is ready for configuration after approximately 40
seconds.

5. Open the Primex SNS Configuration Tool. Go to All Programs > Primex SNS > SNS Configuration Tool or double-click the
SNS Configuration Tool icon on your computer desktop.

6. From the Enter Password window, enter the password.

Note:
Factory default password (case sensitive): Primex1

7. From the bottom right section, select Connect or select Actions> Connect to establish a connection to the clock.

8. Verify the status bar at the bottom of the window displays Device Information Read!. If Connection Failed! is displayed, the
connection to the clock failed.

9. Next, open the .pwg file downloaded from the gateway profile. By default, the file is saved to your computer's Downloads folder
with a file name of device.pwg. From the top menu, select File > Open, browse to the file location and select the .pwg file. The
top title bar displays the name of the file opened; Primex SNS Configuration Tool - name of the .pwg file.

10. From the bottom right section, select Write Configuration or select Actions > Write Configuration. The settings of the .pwg
file are uploaded to the clock, including your OneVue account ID and the gateway profile's network settings. Verify the
notification area displays Configuration written to Device! Device Disconnected!. An analog clock emits three beeps.

If themanual configuration file did not include a network profile or you need to enter the network settings, complete
the steps below.

It may be required to enter the network settings if a network profile was not assigned to the device during device configuration,
you are troubleshooting device network connectivity issues, your information security policies restrict storing network setting data
in third-party applications, or a device factory reset was performed.

1. Reconnect to the clock.

2. From the bottom right menu, select Edit.

3. Enter the network settings the clock gateway will use to connect to your facility's network.

For wireless network use, select the Wireless: Primary tab and enter the settings of the wireless network.

For a wired network use, select the Wired: Primary tab and enter the settings of the wired network.

For use with a non-DHCP network, deselect the DHCP checkbox and enter the additional required settings.
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4. From the bottom right section, select Write Configuration. The network settings are uploaded to the clock gateway.

When the clock checks-in to your OneVue account, if its gateway has an assigned network, alternate or migration network, the
network profiles are downloaded to the clock.

To install a Radius EAP-TLS certificate

1. Select the EAP-TLS Certificate tab.

2. From the certificate file, select Open and select the certificate file (.pem file required).

3. From the bottom right section, select Write Configuration. The certificate file is uploaded to the clock gateway.

11. Remove the Ethernet cable from the clock and computer. For PoE models, do not remove Ethernet cable from clock and connect
the other end of the Ethernet cable to a PoE enabled LAN port.

12. You will now initiate the clock's check-in to your OneVue account.

For a... Then...

Analog Clock Quickly press and release the button on the back of the clock to initiate a check-in.

The clock emits a double-beep when the check-in sequence has started.

The clock emits another series of beeps indicating the clock is connecting to your facility’s network to check-in
to your OneVue account and synchronize its time with an NTP Server.

l One beep - initialized its radio

l Two beeps - connected to network

l Three beeps - received NTP time

l Four beeps - connected to OneVue

After approximately 20 to 30 seconds, the clock automatically set its time.

It's recommended to validate the clock can successfully check-in at its permanent installation location.

Classis Series
Digital LED
Clock/Timer

Press and release the Reset button located in the top panel.

The four LED circle segments illuminate in sequence, indicating the following check-in connection sequence. . ‘-
- - -‘ is shown on the LED display while the clock is waiting for the synchronized NTP time

1 LED circle - initialized its radio

2 LED circles - connected to network

3 LED circles - received NTP time

4 LED circles - connected to OneVue

After approximately 20 to 30 seconds, the clock automatically set its time.

Replace the top panel insert.

It's recommended to validate the clock can successfully check-in at its permanent installation location.
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For a... Then...

Personal Series LCD
Clock

Quickly press and release the button on the back of the clock to initiate a check-in.

The clock emits a single beep when the check-in sequence has started. The check-in sequence takes
approximately 20 to 30 seconds to complete.

Once the clock has successfully checked-in and synchronized its time with the NTP Server, it emits one beep
and automatically sets its time.

It's recommended to validate the clock can successfully check-in at its permanent installation location

Before configuring additional clocks, it's recommend to log into your OneVue account and verify the clock successfully checked-in to
your OneVue account.

Note:
If you completed this procedure due to the settings of the network profile assigned during device preconfiguration were not
correct and a migration network was assigned to the gateway profile, the migration network is downloaded to the clock
gateway during its check-in. Upon a successful connection to the migration network, the system automatically sets its network
to the migration network.

Levo Series Digtial Clocks/Timers Models > Step 2 - upload manual configuration file to clock

The second step of manually configuring the network settings of clock gateway is to upload the manual configuration file downloaded
from the gateway profile to the clock.

Requirements

l Levo Series Digital Clocks/Timers only - install the Primex Device Configuration software on to your computer. The software can
be download from the online help.

l Primex device USB configuration cable (supplied with device order)

l Manual configuration file (.pwg extension) - downloaded from the gateway profile. If the gateway profile did not have an
assigned network, you will be required to enter the network settings during this procedure.

l For EAP-TLS authentication, the certificate .der file is required. This file is uploaded to the clock during configuration.

To uploadmanual configuration file to clock

1. If the clock is mounted, dismount the clock to allow access to the back of the clock.

2. If the clock is powered, remove power from the clock - be sure the clock is not plugged in to AC-power.

3. Plug the Primex USB configuration cable into a USB port on your computer.

4. Plug the configuration cable mini-USB connector into the device USB mini port located on the back side of the clock. The clock
automatically powers up, detects the connection to your computer and enters configuration mode.

5. Open the Primex Device Configuration software. Go to All Programs > Primex > Primex Device Configuration or from your
computer desktop, double-click on the Primex Device Configuration icon.

Note:
Factory default password (case sensitive): Primex1
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6. Select Connect. A connection between your computer and the device is established.

7. Verify the notification area located in the lower-left of the screen, displays Connected to device on COMx, which indicates the
connection has been established.

8. Next, you will open the .pwg file downloaded from the gateway profile. From the top menu, select File, browse to the file location
and select the .pwg file. The default file name is device.pwg

9. Next, you will open the .pwg file downloaded from the gateway profile. From the top menu, select File, browse to the file location
and select the .pwg file. The default file name is device.pwg

If themanual configuration file did not include a network profile or you need to enter the network settings, complete the
steps below. Otherwise, proceed to step 10.

It may be required to enter the network settings if a network profile was not assigned to the device during device configuration, you
are troubleshooting device network connectivity issues, your information security policies restrict storing network setting data in third-
party applications, or a device factory reset was performed.

1. Enter the network settings the gateway will use to connect to your facility's network.

For wireless network use, select the Wireless 1 tab and enter the settings of the wireless network.

For a wired network use, select the Wired tab and enter the settings of the wired network.

For use with a non-DHCP network, deselect the DHCP checkbox and enter the additional required settings.

2. Select Write Configuration. From the Confirmation Needed window, select Yes. The network settings have been uploaded to
the device. Proceed to step 10.

If the gateway profile has an assigned network, alternate or migration network, the network profiles are downloaded to the device
during its next check-in to your OneVue account.

To install a Radius EAP-TLS certificate

1. Select the RADIUS Certificate tab.

2. For each of the certificates, select Open and select the certificate file (.der file required).

3. Select Write Configuration. From the Confirmation Needed window, select Yes. The network settings have been uploaded to
the device. Proceed to step 10.

10. Select Disconnect. The connection between the software and clock is ended.

11. Remove the USB connection between the clock and your computer.

12. Apply power to the clock. When power was applied, the device automatically initiated a check-in to your OneVue account. If there
were pending firmware updates downloaded during its check-in, the clock resets and checks- in a second time.

Before configuring additional clocks, it's recommend to log into your OneVue account and verify the clock successfully checked-in to
your OneVue account.

Note:
If you completed this procedure due to the settings of the network profile assigned during device preconfiguration were not
correct and a migration network was assigned to the gateway profile, the migration network is downloaded to the clock
gateway during its check-in. Upon a successful connection to the migration network, the system automatically sets its network to
the migration network.
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TECHNICAL SUPPORT

You may require Technical Support when you have questions about product features, system configuration or troubleshooting. Support
services are delivered in accordance with your organization's support agreement, end user licenses agreements, and warranties, either
with a Primex Certified Sales and Service Partner or directly with Primex.

Support through Primex Certified Sales and Service Partners

Ensuring our customers experience excellent service is of utmost importance to Primex. Our network of Certified Sales and Service
Partners offer technical support services for Primex products.

If you have purchased Primex products or have a service agreement with a Primex Partner, they are your primary contact for all
Technical Support inquires.

When contacting Primex Technical Support

Make sure you have satisfied the system requirements that are listed in your product documentation. Also, you should be at the
computer or device on which the problem occurred, in case it's necessary to replicate the problem.

When you contact Primex Technical Support, please have the following information available:

l Customer ID/Account Name

l Problem description/error messages

l Device hardware information

l Troubleshooting performed before contacting Primex

l Recent network changes

Primex Technical Support

Hours 8:00 a.m. to 5:00 p.m. CST | Monday through Friday

Phone: 1-262-729-4860

Email: techsupport@primexinc.com

Web: www.primexinc.com/support
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